PrevUpHomeNext

Prerequisites

synkronize was made with independency from operating systems in mind, with only a tiny fraction of platform-dependent code retrieving system or user locale settings.

Using synkronize

Including synkronize headers requires a compiler supporting C++20, from which the following mandatory features are used:

  1. 3-way comparison of onset names
  2. defaulted comparison operators
  3. constant evaluation (std::is_constant_evaluated)

At the time of writing the following compilers are known to work:

3rd-party Dependencies

  1. The Boost Date Time library from Boost 1.73 or later
macos
  1. CoreFoundation framework

Compilation

msvc
  1. define _SILENCE_CXX17_CODECVT_HEADER_DEPRECATION_WARNING when using boost property tree io functionality (defined in ptree_io.h)

Building synkronize

Building synkronize requires a compiler supporting C++20.


PrevUpHomeNext